<!doctype html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    
	<!-- This site is optimized with the Yoast SEO plugin v15.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Dom Lagana Returns Home; 103 Days in the Hospital</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Dom Lagana Returns Home; 103 Days in the Hospital" />
	<meta property="og:description" content="Back in August, Dom Lagana was involved in a single car crash the night of..." />
	<meta property="og:url" content="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" />
	<meta property="og:site_name" content="DragCoverage" />
	<meta property="article:published_time" content="2020-12-03T01:23:02+00:00" />
	<meta property="article:modified_time" content="2020-12-03T01:23:03+00:00" />
	<meta property="og:image" content="http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136.jpg" />
	<meta property="og:image:width" content="782" />
	<meta property="og:image:height" content="1014" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="admin">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="1 minute">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://dragcoverage.com/#website","url":"https://dragcoverage.com/","name":"DragCoverage","description":"Your #1 Source for Drag Racing News and Results","potentialAction":[{"@type":"SearchAction","target":"https://dragcoverage.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/#primaryimage","inLanguage":"en-US","url":"http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136.jpg","width":782,"height":1014},{"@type":"WebPage","@id":"http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/#webpage","url":"http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/","name":"Dom Lagana Returns Home; 103 Days in the Hospital","isPartOf":{"@id":"https://dragcoverage.com/#website"},"primaryImageOfPage":{"@id":"http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/#primaryimage"},"datePublished":"2020-12-03T01:23:02+00:00","dateModified":"2020-12-03T01:23:03+00:00","author":{"@id":"https://dragcoverage.com/#/schema/person/22fc5867c06d7f4ab7acdfadbfd32981"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/"]}]},{"@type":"Person","@id":"https://dragcoverage.com/#/schema/person/22fc5867c06d7f4ab7acdfadbfd32981","name":"admin","image":{"@type":"ImageObject","@id":"https://dragcoverage.com/#personlogo","inLanguage":"en-US","url":"http://1.gravatar.com/avatar/76b0d68bee7308f1b2783b4b5b4c3d64?s=96&r=g","caption":"admin"},"description":"TJ Pruitt is the publisher of DragCoverage.com. To submit your news, email us at coverage@dragcoverage.com"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="DragCoverage &raquo; Feed" href="http://dragcoverage.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="DragCoverage &raquo; Comments Feed" href="http://dragcoverage.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/dragcoverage.com\/news\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://dragcoverage.com/news/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpemfb-lightbox-css'  href='http://dragcoverage.com/news/wp-content/plugins/wp-embed-facebook/templates/lightbox/css/lightbox.css?ver=3.0.10' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-v5-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/font-awesome-v5/css/fontawesome-all.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/slick/css/slick.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/magnific-popup/magnific-popup.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='sliderpro-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/slider-pro/css/slider-pro.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='covernews-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Source%20Sans%20Pro:400,400i,700,700i|Source%20Sans%20Pro:400,400i,700,700i&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='covernews-style-css'  href='http://dragcoverage.com/news/wp-content/themes/covernews-pro/style.css?ver=5.5.3' type='text/css' media='all' />
<style id='covernews-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpshopify-styles-frontend-all-css'  href='http://dragcoverage.com/news/wp-content/plugins/wp-shopify-pro/dist/public.min.css?ver=1597961686' type='text/css' media='all' />
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/plugins/wp-embed-facebook/templates/lightbox/js/lightbox.min.js?ver=3.0.10' id='wpemfb-lightbox-js'></script>
<script type='text/javascript' id='wpemfb-fbjs-js-extra'>
/* <![CDATA[ */
var WEF = {"local":"en_US","version":"v6.0","fb_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/plugins/wp-embed-facebook/inc/js/fb.min.js?ver=3.0.10' id='wpemfb-fbjs-js'></script>
<script type='text/javascript' defer src='http://dragcoverage.com/news/wp-content/plugins/wp-shopify-pro/dist/runtime.8e288f.min.js?ver=5.5.3' id='wpshopify-runtime-js'></script>
<script type='text/javascript' defer src='http://dragcoverage.com/news/wp-content/plugins/wp-shopify-pro/dist/vendors-public.8e288f.min.js?ver=5.5.3' id='wpshopify-vendors-public-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="http://dragcoverage.com/news/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/hooks.min.js?ver=b4778690e29d8a2b7518413652ba30c4' id='wp-hooks-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.15' id='lodash-js'></script>
<script type='text/javascript' id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/vendor/react.min.js?ver=16.9.0' id='react-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.9.0' id='react-dom-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/escape-html.min.js?ver=f7b0e4c8bb987c1ab79bdda0d9db465b' id='wp-escape-html-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/element.min.js?ver=d061952232722fcef7dbe8a686d9996f' id='wp-element-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/vendor/moment.min.js?ver=2.26.0' id='moment-js'></script>
<script type='text/javascript' id='moment-js-after'>
moment.updateLocale( 'en_US', {"months":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthsShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"weekdays":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"weekdaysShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"week":{"dow":1},"longDateFormat":{"LT":"g:i a","LTS":null,"L":null,"LL":"F j, Y","LLL":"F j, Y g:i a","LLLL":null}} );
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/dom-ready.min.js?ver=db63eb2f693cb5e38b083946b14f0684' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/i18n.min.js?ver=bb7c3c45d012206bfcd73d6a31f84d9e' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/a11y.min.js?ver=13971b965470c74a60fa32d392c78f2f' id='wp-a11y-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/is-shallow-equal.min.js?ver=faf996f5d8657ed8cb4e326307229895' id='wp-is-shallow-equal-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/priority-queue.min.js?ver=25df4fcfc831934f96ee620ba97b8d72' id='wp-priority-queue-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/compose.min.js?ver=c4775e2aa9288586791e26a980eff851' id='wp-compose-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/deprecated.min.js?ver=99b042a92d284c1276e553789c674cab' id='wp-deprecated-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/dom.min.js?ver=3f7b757d117b8e53e66943297e96bf38' id='wp-dom-js'></script>
<script type='text/javascript' id='wp-keycodes-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/keycodes.min.js?ver=d22da43ca8a6cd671dd34ea661fff05f' id='wp-keycodes-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/primitives.min.js?ver=29a6188bba37f7dd03ab293172d040cd' id='wp-primitives-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/redux-routine.min.js?ver=9c464c6fba42fc0112f5feedb4939fa6' id='wp-redux-routine-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/data.min.js?ver=75f90354ddff4acd5b0b4026454037ca' id='wp-data-js'></script>
<script type='text/javascript' id='wp-data-js-after'>
( function() {
	var userId = 0;
	var storageKey = "WP_DATA_USER_" + userId;
	wp.data
		.use( wp.data.plugins.persistence, { storageKey: storageKey } );
	wp.data.plugins.persistence.__unstableMigrate( { storageKey: storageKey } );
} )();
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/rich-text.min.js?ver=a4056cfcb2aec8ceb3c8e8935dfd0bc4' id='wp-rich-text-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/warning.min.js?ver=4846e6a00f535179609298debad4670b' id='wp-warning-js'></script>
<script type='text/javascript' id='wp-components-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/dist/components.min.js?ver=2152e06558875aa948807b6ffd5da769' id='wp-components-js'></script>
<script type='text/javascript' id='wpshopify-public-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "wpshopify", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' id='wpshopify-public-js-before'>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</script>
<script type='text/javascript' defer src='http://dragcoverage.com/news/wp-content/plugins/wp-shopify-pro/dist/public.8e288f.min.js?ver=5.5.3' id='wpshopify-public-js'></script>
<link rel="https://api.w.org/" href="http://dragcoverage.com/wp-json/" /><link rel="alternate" type="application/json" href="http://dragcoverage.com/wp-json/wp/v2/posts/10700" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://dragcoverage.com/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://dragcoverage.com/news/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='http://dragcoverage.com/?p=10700' />
<link rel="alternate" type="application/json+oembed" href="http://dragcoverage.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragcoverage.com%2Fdom-lagana-returns-home-103-days-in-the-hospital%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://dragcoverage.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdragcoverage.com%2Fdom-lagana-returns-home-103-days-in-the-hospital%2F&#038;format=xml" />
<style>#wpdevart_lb_overlay{background-color:#000000;} #wpdevart_lb_overlay.wpdevart_opacity{opacity:0.78 !important;} #wpdevart_lb_main_desc{
				 -webkit-transition: opacity 0.3s ease;
				 -moz-transition: opacity 0.3s ease;
				 -o-transition: opacity 0.3s ease;
				 transition: opacity 0.3s ease;} #wpdevart_lb_information_content{
				 -webkit-transition: opacity 0.3s ease;
				 -moz-transition: opacity 0.3s ease;
				 -o-transition: opacity 0.3s ease;
				 transition: opacity 0.3s ease;}
		#wpdevart_lb_information_content{
			width:100%;	
		}
		#wpdevart_info_counter_of_imgs{
			    display: inline-block;
				padding-left:15px;
				padding-right:4px;
				font-size:20px;
				color:#000000;
		}
		#wpdevart_info_caption{
			    display: inline-block;
				padding-left:15px;
				padding-right:4px;
				font-size:20px;
				color:#000000;
		}
		#wpdevart_info_title{
			    display: inline-block;
				padding-left:4px;
				padding-right:4px;
				font-size:15px;
				color:#000000;
		}
		@-webkit-keyframes rotate {
			to   {-webkit-transform: rotate(360deg);}
			from  {-webkit-transform: rotate(0deg);}
		}
		@keyframes rotate {
			to   {transform: rotate(360deg);}
			from  {transform: rotate(0deg);}
		}
		#wpdevart_lb_loading_img,#wpdevart_lb_loading_img_first{
			-webkit-animation: rotate 2s linear  infinite;
    		animation: rotate 2s linear infinite;
		}
	  </style>      <script type='text/javascript'>
/* <![CDATA[ */
var VPData = {"__":{"couldnt_retrieve_vp":"Couldn&#039;t retrieve Visual Portfolio ID.","pswp_close":"Close (Esc)","pswp_share":"Share","pswp_fs":"Toggle fullscreen","pswp_zoom":"Zoom in\/out","pswp_prev":"Previous (arrow left)","pswp_next":"Next (arrow right)","pswp_share_fb":"Share on Facebook","pswp_share_tw":"Tweet","pswp_share_pin":"Pin it","fancybox_close":"Close","fancybox_next":"Next","fancybox_prev":"Previous","fancybox_error":"The requested content cannot be loaded. <br \/> Please try again later.","fancybox_play_start":"Start slideshow","fancybox_play_stop":"Pause slideshow","fancybox_full_screen":"Full screen","fancybox_thumbs":"Thumbnails","fancybox_download":"Download","fancybox_share":"Share","fancybox_zoom":"Zoom"},"settingsPopupGallery":{"enable_on_wordpress_images":false,"vendor":"fancybox","deep_linking":false,"deep_linking_url_to_share_images":false,"show_arrows":true,"show_counter":true,"show_zoom_button":true,"show_fullscreen_button":true,"show_share_button":true,"show_close_button":true,"show_thumbs":true,"show_download_button":false,"show_slideshow":false,"click_to_zoom":true},"screenSizes":[320,576,768,992,1200]};
/* ]]> */
</script>
        <style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            

        </style>
        <link rel="icon" href="http://dragcoverage.com/news/wp-content/uploads/2020/08/cropped-dc2016-Recovered-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://dragcoverage.com/news/wp-content/uploads/2020/08/cropped-dc2016-Recovered-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="http://dragcoverage.com/news/wp-content/uploads/2020/08/cropped-dc2016-Recovered-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://dragcoverage.com/news/wp-content/uploads/2020/08/cropped-dc2016-Recovered-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			@media (min-width: 1200px)
{
.container {
    width: 1100px !important;
}
}		</style>
		</head>

<body class="post-template-default single single-post postid-10700 single-format-standard wp-custom-logo wp-embed-responsive default-content-layout align-content-left wpshopify">
    
    <div id="af-preloader">
        <div id="loader-wrapper">
            <div id="loader"></div>
        </div>
    </div>

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

<div class="header-layout-1">
    <div class="top-masthead">

        <div class="container">
            <div class="row">
                                    <div class="col-xs-12 col-sm-12 col-md-8 device-center">
                        
                        <div class="top-navigation"><ul id="top-menu" class="menu"><li id="menu-item-9952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9952"><a href="https://demo.afthemes.com/covernews-pro">Home</a></li>
<li id="menu-item-9961" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-9961"><a href="http://dragcoverage.com/type/video/">Video</a></li>
</ul></div>                    </div>
                                            </div>
        </div>
    </div> <!--    Topbar Ends-->
<header id="masthead" class="site-header">
        <div class="masthead-banner " data-background="">
        <div class="container">
            <div class="row">
                <div class="col-md-4">
                    <div class="site-branding">
                        <a href="http://dragcoverage.com/" class="custom-logo-link" rel="home"><img width="600" height="225" src="http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo.png" class="custom-logo" alt="DragCoverage" srcset="http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo.png 600w, http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo-300x113.png 300w" sizes="(max-width: 600px) 100vw, 600px" /></a>                            <p class="site-title font-family-1">
                                <a href="http://dragcoverage.com/"
                                   rel="home">DragCoverage</a>
                            </p>
                        
                                                    <p class="site-description">Your #1 Source for Drag Racing News and Results</p>
                                            </div>
                </div>
                <div class="col-md-8">
                                <div class="banner-promotions-wrapper">
                                    <div class="promotion-section">
                        <a href="https://www.strangeengineering.net/" target="_blank">
                            <img width="800" height="115" src="http://dragcoverage.com/news/wp-content/uploads/2020/08/strangebrakes.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="http://dragcoverage.com/news/wp-content/uploads/2020/08/strangebrakes.jpg 800w, http://dragcoverage.com/news/wp-content/uploads/2020/08/strangebrakes-300x43.jpg 300w, http://dragcoverage.com/news/wp-content/uploads/2020/08/strangebrakes-768x110.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" />                        </a>
                    </div>
                                

            </div>
            <!-- Trending line END -->
                            </div>
            </div>
        </div>
    </div>
    <nav id="site-navigation" class="main-navigation">
        <div class="container">
            <div class="row">
                <div class="kol-12">
                    <div class="navigation-container">





                        <button class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                        </button>
                        <span class="af-mobile-site-title-wrap">
                            <a href="http://dragcoverage.com/" class="custom-logo-link" rel="home"><img width="600" height="225" src="http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo.png" class="custom-logo" alt="DragCoverage" srcset="http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo.png 600w, http://dragcoverage.com/news/wp-content/uploads/2020/08/dclogo-300x113.png 300w" sizes="(max-width: 600px) 100vw, 600px" /></a>                            <p class="site-title font-family-1">
                                <a href="http://dragcoverage.com/"
                                   rel="home">DragCoverage</a>
                            </p>
                        </span>
                        <div class="menu main-menu"><ul id="primary-menu" class="menu"><li id="menu-item-10032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-10032"><a href="http://dragcoverage.com/">HOME</a></li>
<li id="menu-item-10173" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10173"><a href="http://dragcoverage.com/collections/">SHOP</a></li>
<li id="menu-item-10170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10170"><a href="http://dragcoverage.com/category/features/">FEATURES</a></li>
<li id="menu-item-10169" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-10169"><a href="http://dragcoverage.com/category/race-coverage/">RACE COVERAGE</a>
<ul class="sub-menu">
	<li id="menu-item-10033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10033"><a href="http://dragcoverage.com/category/race-coverage/bracket-racing/">BRACKET RACING</a></li>
	<li id="menu-item-10034" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10034"><a href="http://dragcoverage.com/category/race-coverage/nhra/">NHRA</a></li>
	<li id="menu-item-10172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10172"><a href="http://dragcoverage.com/category/race-coverage/pdra/">PDRA</a></li>
</ul>
</li>
<li id="menu-item-8841" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8841"><a href="#">ADVERTISEMENT</a></li>
<li id="menu-item-8843" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8843"><a href="#">CONTACT</a></li>
</ul></div>
                        <div class="cart-search">
                            <div class="af-search-wrap">
                                <div class="search-overlay">
                                    <a href="#" title="Search" class="search-icon">
                                        <i class="fa fa-search"></i>
                                    </a>
                                    <div class="af-search-form">
                                        <form role="search" method="get" class="search-form" action="http://dragcoverage.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                                    </div>
                                </div>
                            </div>
                        </div>


                    </div>
                </div>
            </div>
        </div>
    </nav>
</header>

</div>

    <div id="content" class="container">


        <div class="em-breadcrumbs font-family-1">
                <div class="row">
                        <div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="4" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="http://dragcoverage.com/" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="http://dragcoverage.com/category/race-coverage/" itemprop="item"><span itemprop="name">Race Coverage</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="http://dragcoverage.com/category/race-coverage/nhra/" itemprop="item"><span itemprop="name">NHRA</span></a><meta itemprop="position" content="3" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" itemprop="item"><span itemprop="name">Dom Lagana Returns Home; 103 Days in the Hospital</span></a><meta itemprop="position" content="4" /></li></ul></div>                </div>
        </div>


            <div class="row">
                <div id="primary" class="content-area">
                    <main id="main" class="site-main">

                                                    <article id="post-10700" class="af-single-article post-10700 post type-post status-publish format-standard has-post-thumbnail hentry category-snipets category-nhra">
                                <div class="entry-content-wrap">
                                    <header class="entry-header">

    <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/nhra/" alt="View all posts in NHRA"> 
                                 NHRA
                             </a>
                        </li></ul>                </div>
                        <h1 class="entry-title">Dom Lagana Returns Home; 103 Days in the Hospital</h1>
            
                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 day ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                        

                    </div>
    </div>
        <div class="aft-post-thumbnail-wrapper">    
                    <div class="post-thumbnail full-width-image">
                    <img width="782" height="1014" src="http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136.jpg" class="attachment-covernews-featured size-covernews-featured wp-post-image" alt="" loading="lazy" srcset="http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136.jpg 782w, http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136-231x300.jpg 231w, http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136-768x996.jpg 768w, http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136-500x648.jpg 500w" sizes="(max-width: 782px) 100vw, 782px" />                </div>
            
                </div>
</header><!-- .entry-header -->                                    

    <div class="entry-content">
        <div id="fb-root"></div>
<p>Back in August, Dom Lagana was involved in a single car crash the night of an NHRA event at Lucas Oil Raceway.</p>
<p>DragCoverage has been following and sharing updates on Dom Lagana’s fight since his accident. We are glad to report that he is home. Dom Lagana is a fighter and we cannot wait to meet him.</p>
<p>Dom Lagana &#8211; “103 days in the hospital since my accident on August 9th and I’m happy to say that I’m finally back home. I had severely bad burns to my body which resulted in my lower legs getting amputated. This hasn’t been an easy journey but I am so lucky to have such an amazing support system around me. I am forever indebted to all the doctors, nurses and therapists who saved my life.</p>
<p>I’ll be continuing outpatient rehab and focused on working toward getting prosthetics.”</p>
<p>“It’s a big life adjustment but I’m so grateful to still be here. Thank you again for everyone’s support and prayers, it means the world to my family and I.”</p>
<p>Post 📸 @lagana142</p>
                    <div class="post-item-metadata entry-meta">
                            </div>
                
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/" rel="prev"><span class="em-post-navigation">Previous</span> “Big Daddy” Ellis Milner turns 84. Happy Birthday</a></div></div>
	</nav>            </div><!-- .entry-content -->


                                </div>
                                
<div class="promotionspace enable-promotionspace">

        <div class="em-reated-posts  col-ten">
        <div class="row">
                            <h3 class="related-title">
                    More Stories                </h3>
                        <div class="row">
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0883-720x380.jpg">
                                        <a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/" alt="View all posts in Features"> 
                                 Features
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/">
                                        “Big Daddy” Ellis Milner turns 84. Happy Birthday                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 week ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/11/final-720x380.jpg">
                                        <a href="http://dragcoverage.com/ezell-baehr-win-day-1-turkey-beach-bash-at-gulfport-dragway/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/bracket-racing/" alt="View all posts in Bracket Racing"> 
                                 Bracket Racing
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/ezell-baehr-win-day-1-turkey-beach-bash-at-gulfport-dragway/">
                                        Ezell &#038; Baehr win Day 1 Turkey Beach Bash at Gulfport Dragway                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    3 weeks ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0237-1-720x380.jpg">
                                        <a href="http://dragcoverage.com/marques-king-kong-hatton-wins-friday-night-frenzy-at-sgmp/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/marques-king-kong-hatton-wins-friday-night-frenzy-at-sgmp/">
                                        Marques “King Kong” Hatton Wins Friday Night Frenzy at SGMP                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    4 weeks ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0130-720x380.jpg">
                                        <a href="http://dragcoverage.com/jason-hallams-new-turbocharged-ls-mustang/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/car-feature/" alt="View all posts in Car Feature"> 
                                 Car Feature
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/" alt="View all posts in Features"> 
                                 Features
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/jason-hallams-new-turbocharged-ls-mustang/">
                                        Jason Hallam’s New Turbocharged LS Mustang                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 month ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/10/img_9819-720x380.jpg">
                                        <a href="http://dragcoverage.com/kevin-brannon-wins-the-25th-annual-million-dollar-drag-race/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/kevin-brannon-wins-the-25th-annual-million-dollar-drag-race/">
                                        Kevin Brannon wins the 25th Annual Million Dollar Drag Race                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 month ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                                    <div class="col-sm-4 latest-posts-grid" data-mh="latest-posts-grid">
                        <div class="spotlight-post">
                            <figure class="categorised-article">
                                <div class="categorised-article-wrapper">
                                    <div class="data-bg data-bg-hover data-bg-categorised"
                                         data-background="http://dragcoverage.com/news/wp-content/uploads/2020/10/img_9727-720x380.jpg">
                                        <a href="http://dragcoverage.com/bailey-ferraro-races-his-way-to-two-straight-finals-and-wins-thursdays-summit-racing-equipment-triple-50k-at-the-million/"></a>
                                    </div>
                                </div>
                            </figure>

                            <figcaption>
                                <div class="figure-categories figure-categories-bg">
                                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/bracket-racing/" alt="View all posts in Bracket Racing"> 
                                 Bracket Racing
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                </div>
                                <h3 class="article-title article-title-1">
                                    <a href="http://dragcoverage.com/bailey-ferraro-races-his-way-to-two-straight-finals-and-wins-thursdays-summit-racing-equipment-triple-50k-at-the-million/">
                                        Bailey Ferraro Races His Way to Two Straight Finals and Wins Thursday&#8217;s Summit Racing Equipment Triple 50K at the Million                                    </a>
                                </h3>
                                <div class="grid-item-metadata">
                                    
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 month ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
                                        </div>
                            </figcaption>
                        </div>
                    </div>
                            </div>

        </div>
    </div>
</div>


                                                            </article>
                        
                    </main><!-- #main -->
                </div><!-- #primary -->
                                
<aside id="secondary" class="widget-area aft-sticky-sidebar">
	<div id="search-6" class="widget covernews-widget widget_search"><form role="search" method="get" class="search-form" action="http://dragcoverage.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="covernews_tabbed_posts-1" class="widget covernews-widget covernews_tabbed_posts_widget">            <div class="tabbed-container">
                <div class="tabbed-head">
                    <ul class="nav nav-tabs af-tabs tab-warpper" role="tablist">
                        <li class="tab tab-recent active">
                            <a href="#tabbed-1-recent"
                               aria-controls="Recent" role="tab"
                               data-toggle="tab" class="font-family-1 widget-title ">
                                Latest                            </a>
                        </li>
                        <li role="presentation" class="tab tab-popular">
                            <a href="#tabbed-1-popular"
                               aria-controls="Popular" role="tab"
                               data-toggle="tab" class="font-family-1">
                                Popular                            </a>
                        </li>

                                                    <li class="tab tab-categorised">
                                <a href="#tabbed-1-categorised"
                                   aria-controls="Categorised" role="tab"
                                   data-toggle="tab" class="font-family-1">
                                    Newsbeat                                </a>
                            </li>
                                            </ul>
                </div>
                <div class="tab-content">
                    <div id="tabbed-1-recent" role="tabpanel" class="tab-pane active">
                        <ul class="article-item article-list-item article-tabbed-list article-item-left">                <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/nhra/" alt="View all posts in NHRA"> 
                                 NHRA
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/">
                                            Dom Lagana Returns Home; 103 Days in the Hospital                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 day ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0883-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/" alt="View all posts in Features"> 
                                 Features
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/">
                                            “Big Daddy” Ellis Milner turns 84. Happy Birthday                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 week ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/ezell-baehr-win-day-1-turkey-beach-bash-at-gulfport-dragway/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/11/final-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/bracket-racing/" alt="View all posts in Bracket Racing"> 
                                 Bracket Racing
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/ezell-baehr-win-day-1-turkey-beach-bash-at-gulfport-dragway/">
                                            Ezell &#038; Baehr win Day 1 Turkey Beach Bash at Gulfport Dragway                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    3 weeks ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/marques-king-kong-hatton-wins-friday-night-frenzy-at-sgmp/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0237-1-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/marques-king-kong-hatton-wins-friday-night-frenzy-at-sgmp/">
                                            Marques “King Kong” Hatton Wins Friday Night Frenzy at SGMP                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    4 weeks ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/jason-hallams-new-turbocharged-ls-mustang/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/11/img_0130-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/car-feature/" alt="View all posts in Car Feature"> 
                                 Car Feature
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/features/" alt="View all posts in Features"> 
                                 Features
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/jason-hallams-new-turbocharged-ls-mustang/">
                                            Jason Hallam’s New Turbocharged LS Mustang                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 month ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
            </ul>                    </div>
                    <div id="tabbed-1-popular" role="tabpanel" class="tab-pane">
                        <ul class="article-item article-list-item article-tabbed-list article-item-left">                <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                    <div class="full-item-details col-details col-sm-12">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/hello-world/">
                                            Hello world!                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    5 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/themewarrior/">
                Andra Yogi            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/vertical-image-is-ok/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2015/04/flower-white-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/vertical-image-is-ok/">
                                            Vertical Image is ok                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/12/img_1136-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/nhra/" alt="View all posts in NHRA"> 
                                 NHRA
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/">
                                            Dom Lagana Returns Home; 103 Days in the Hospital                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    1 day ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/todd-dejoria-enders-stevens-krawiec-will-lead-fields-into-charlotte-eliminations/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2014/09/fritease-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/nhra/" alt="View all posts in NHRA"> 
                                 NHRA
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/todd-dejoria-enders-stevens-krawiec-will-lead-fields-into-charlotte-eliminations/">
                                            Todd, DeJoria, Enders-Stevens, Krawiec will lead fields into Charlotte eliminations                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/pdra-extends-invitation-to-pro-stock-for-2015/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2014/09/pdra-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/pdra/" alt="View all posts in PDRA"> 
                                 PDRA
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/pdra-extends-invitation-to-pro-stock-for-2015/">
                                            PDRA Extends Invitation to Pro Stock for 2015                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
            </ul>                    </div>
                                            <div id="tabbed-1-categorised" role="tabpanel" class="tab-pane">
                            <ul class="article-item article-list-item article-tabbed-list article-item-left">                <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/2020-pri-trade-show-cancelled/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/09/img_7679-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/snipets/" alt="View all posts in DC Snipets"> 
                                 DC Snipets
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/upcoming-event/" alt="View all posts in Events"> 
                                 Events
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/2020-pri-trade-show-cancelled/">
                                            2020 PRI Trade Show Cancelled                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    3 months ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/nhra-announces-revised-schedule-for-mello-yello-drag-racing-series/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2020/03/img_0278-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/breaking-news/" alt="View all posts in Breaking News"> 
                                 Breaking News
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/upcoming-event/" alt="View all posts in Events"> 
                                 Events
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/nhra/" alt="View all posts in NHRA"> 
                                 NHRA
                             </a>
                        </li><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/race-coverage/" alt="View all posts in Race Coverage"> 
                                 Race Coverage
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/nhra-announces-revised-schedule-for-mello-yello-drag-racing-series/">
                                            NHRA announces revised schedule for Mello Yello Drag Racing Series                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    8 months ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/2015-memphis-25k-showdowns/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2015/04/IMG_32831-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/upcoming-event/" alt="View all posts in Events"> 
                                 Events
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/2015-memphis-25k-showdowns/">
                                            2015 Memphis 25k Showdowns                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/bradenton-5-day-is-back-nov-14-18/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2014/10/20141009-101154-150x150.jpg"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/upcoming-event/" alt="View all posts in Events"> 
                                 Events
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/bradenton-5-day-is-back-nov-14-18/">
                                            Bradenton 5- Day is back; November 14-18                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
                            <li class="full-item clearfix">
                    <div class="base-border">
                        <div class="row-sm align-items-center">
                                                                                        <div class="col-sm-4 col-image">

                                        <div class="tab-article-image">
                                            <a href="http://dragcoverage.com/dragcoverage-com-nationals-invades-atmore-this-weekend/" class="post-thumb">
                                                <img src="http://dragcoverage.com/news/wp-content/uploads/2014/09/fewmoredays-150x150.png"/>
                                            </a>
                                        </div>
                                         
                                </div>
                                                        <div class="full-item-details col-details col-sm-8">
                            <div class="prime-row">    
                                <div class="full-item-metadata primary-font">
                                    <div class="figure-categories figure-categories-bg clearfix">
                                       
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="covernews-categories category-color-1" href="http://dragcoverage.com/category/upcoming-event/" alt="View all posts in Events"> 
                                 Events
                             </a>
                        </li></ul>                                    </div>
                                </div>
                                <div class="full-item-content">
                                    <h3 class="article-title article-title-1">
                                        <a href="http://dragcoverage.com/dragcoverage-com-nationals-invades-atmore-this-weekend/">
                                            DragCoverage.com Nationals Invades Atmore This Weekend                                        </a>
                                    </h3>
                                    <div class="grid-item-metadata">
                                                                                
        <span class="author-links">
                            <span class="item-metadata posts-date">
                <i class="far fa-clock"></i>
                    6 years ago            </span>
                        
                <span class="item-metadata posts-author">
            <a href="http://dragcoverage.com/author/admin/">
                admin            </a>
        </span>
                    </span>
        
                                    </div>
                                                                    </div>
                            </div>
                            </div>
                        </div>
                    </div>
                </li>
            </ul>                        </div>
                                    </div>
            </div>
            </div>
		<div id="recent-posts-3" class="widget covernews-widget widget_recent_entries">
		<h2 class="widget-title widget-title-1"><span>Recent Posts</span></h2>
		<ul>
											<li>
					<a href="http://dragcoverage.com/dom-lagana-returns-home-103-days-in-the-hospital/" aria-current="page">Dom Lagana Returns Home; 103 Days in the Hospital</a>
									</li>
											<li>
					<a href="http://dragcoverage.com/big-daddy-ellis-milner-turns-84-happy-birthday/">“Big Daddy” Ellis Milner turns 84. Happy Birthday</a>
									</li>
											<li>
					<a href="http://dragcoverage.com/ezell-baehr-win-day-1-turkey-beach-bash-at-gulfport-dragway/">Ezell &#038; Baehr win Day 1 Turkey Beach Bash at Gulfport Dragway</a>
									</li>
											<li>
					<a href="http://dragcoverage.com/marques-king-kong-hatton-wins-friday-night-frenzy-at-sgmp/">Marques “King Kong” Hatton Wins Friday Night Frenzy at SGMP</a>
									</li>
											<li>
					<a href="http://dragcoverage.com/jason-hallams-new-turbocharged-ls-mustang/">Jason Hallam’s New Turbocharged LS Mustang</a>
									</li>
					</ul>

		</div></aside><!-- #secondary -->
            </div>


</div>


    <div class="mailchimp-block">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                    <h3 class="block-title text-center">
                        Subscribe To  Our Newsletter                    </h3>
                </div>
            </div>
        </div>
        <div class="container">
            <div class="row">
                <div class="col-sm-8 col-sm-offset-2">
                    [mc4wp_form id="69"]                </div>
            </div>
        </div>
    </div>
    
<footer class="site-footer">
        
        <div class="site-info">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                                                                Copyright 2020 © DragCoverage Magazine. All rights reserved.                                                                            </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
<div id="wpshopify-root"></div><div
   data-wpshopify-component
   data-wpshopify-component-type="cart"
   data-wpshopify-payload-settings="eyJyZW5kZXJfZnJvbV9zZXJ2ZXIiOmZhbHNlLCJpY29uIjpmYWxzZSwidHlwZSI6ImZpeGVkIiwiaW5saW5lX2JhY2tncm91bmRfY29sb3IiOiIjNmFlMDZhIiwiaW5saW5lX2NhcnRfY291bnRlcl90ZXh0X2NvbG9yIjoiIzAwMCIsImlubGluZV9pY29uX2NvbG9yIjoiIzAwMCIsInNob3dfY291bnRlciI6dHJ1ZSwiZGF0YV90eXBlIjpmYWxzZSwiaGlkZV93cmFwcGVyIjpmYWxzZSwiZml4ZWRfYmFja2dyb3VuZF9jb2xvciI6IiMwMDAwMDAiLCJmaXhlZF9jb3VudGVyX2NvbG9yIjoiI0ZGRiIsImZpeGVkX2ljb25fY29sb3IiOiIjRkZGIn0=">
   
         <style>
         .menu-item [data-wpshopify-component-type="cart"] {
            width: 100%;
            height: 100%;
            display: flex;
            justify-content: center;
            align-items: center;
         }
      </style>
   </div><link rel='stylesheet' id='wpdevart_lightbox_front_end_css-css'  href='http://dragcoverage.com/news/wp-content/plugins/lightbox-popup/includes/style/wpdevart_lightbox_front.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpdevart_lightbox_effects-css'  href='http://dragcoverage.com/news/wp-content/plugins/lightbox-popup/includes/style/effects_lightbox.css?ver=5.5.3' type='text/css' media='all' />
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/js/navigation.js?ver=20151215' id='covernews-navigation-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/js/skip-link-focus-fix.js?ver=20151215' id='covernews-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/slick/js/slick.min.js?ver=5.5.3' id='slick-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/bootstrap/js/bootstrap.min.js?ver=5.5.3' id='bootstrap-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/sidr/js/jquery.sidr.min.js?ver=5.5.3' id='sidr-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/magnific-popup/jquery.magnific-popup.min.js?ver=5.5.3' id='magnific-popup-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/slider-pro/js/jquery.sliderPro.min.js?ver=5.5.3' id='sliderpro-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/jquery-match-height/jquery.matchHeight.min.js?ver=5.5.3' id='matchheight-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/marquee/jquery.marquee.js?ver=5.5.3' id='marquee-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=5.5.3' id='sticky-sidebar-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/script.js?ver=5.5.3' id='covernews-script-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/themes/covernews-pro/assets/fixed-header-script.js?ver=5.5.3' id='covernews-fixed-header-script-js'></script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script type='text/javascript' id='wpdevart_lightbox_front_end_js-js-extra'>
/* <![CDATA[ */
var wpdevart_lb_variables = {"eneble_lightbox_content":"enable","overlay_transparency_prancent":"78","enable_video_popuping":"enable","popup_background_color":"#ffffff","popup_loading_image":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/popup_loading.png","popup_initial_width":"800","popup_initial_height":"800","popup_youtube_width":"640","popup_youtube_height":"408","popup_vimeo_width":"500","popup_vimeo_height":"409","popup_max_width":"5000","popup_max_height":"5000","popup_position":"5","popup_fixed_position":"true","popup_outside_margin":"0","popup_border_width":"1","popup_border_color":"#000000","popup_border_radius":"20","control_buttons_show":"true","control_buttons_show_in_content":"true","control_buttons_height":"40","control_buttons_line_bg_color":"#000000","control_button_prev_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/prev.png","control_button_prev_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/prev_hover.png","control_button_next_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/next.png","control_button_next_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/next_hover.png","control_button_download_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/download.png","control_button_download_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/download_hover.png","control_button_innewwindow_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/innewwindow.png","control_button_innewwindow_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/innewwindow_hover.png","control_button_fullwidth_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/fullwidth.png","control_button_fullwidht_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/fullwidth_hover.png","control_button_fullwidthrest_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/fullwidthreset.png","control_button_fullwidhtrest_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/fullwidthreset_hover.png","control_button_close_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/close.png","control_button_close_hover_img_src":"http:\/\/dragcoverage.com\/news\/wp-content\/plugins\/lightbox-popup\/images\/contorl_buttons\/close_hover.png","information_panel_show":"true","information_panel_show_in_content":"true","information_panel_bg_color":"#000000","information_panel_default_transparency":"75","information_panel_hover_trancparency":"100","information_panel_count_image_after_text":"Image","information_panel_count_image_middle_text":"of","information_panel_count_padding_left":"15","information_panel_count_padding_right":"4","information_panel_count_font_size":"20","information_panel_desc_padding_left":"15","information_panel_desc_padding_right":"4","information_panel_desc_font_size":"20","information_panel_desc_show_if_not":"true","information_panel_text_for_no_caption":"No Caption","information_panel_title_padding_left":"4","information_panel_title_padding_right":"4","information_panel_title_font_size":"15","information_panel_title_show_if_not":"true","information_panel_text_for_no_title":"No Title","information_panel_ordering":"{\"count\":[1,\"count\"],\"title\":[0,\"title\"],\"caption\":[0,\"caption\"]}"};
/* ]]> */
</script>
<script type='text/javascript' src='http://dragcoverage.com/news/wp-content/plugins/lightbox-popup/includes/javascript/wpdevart_lightbox_front.js?ver=1.0' id='wpdevart_lightbox_front_end_js-js'></script>
</body>
</html>
